RIAトピックス
リッチクライアント/RIAを主テーマに取り扱います。Flex、Ajax、AIR、Silverlight、JavaFX、etc。
スポンサーサイト
上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。

IPAが2009年度上期の未踏採択プロジェクトを決定
日本語プログラミング言語「言霊」など,IPAが2009年度上期の未踏採択プロジェクトを決定  【ITproより】
http://itpro.nikkeibp.co.jp/article/NEWS/20090801/334752/

IPA(独立行政法人情報処理推進機構)が未踏採択プロジェクトを決定したようです。
これは独創的なアイディア、技術を持つクリエーターをマネージメントしてくれるというものらしいです。

様々なアイディアが寄せられていましたが、決定テーマのみしか公表されておらず概要などは今後発表があるそうです。
なので、いまいち興味をひきませんでしたが、懲りもせず日本語プログラミング言語を開発するみたいなので調べてみました。

日本語でプログラミングとはいまいち想像しずらいかと思いますが。。。
以下のような感じで作成していきます。(日本語プログラミング言語なでしこの場合)

天気=「晴れ」
もし、天気が「晴れ」ならば
  「遠足に行く」を表示
違えば
  「遠足は延期」を表示


そのままと言えばそのままでしょうが、まったくプログラミングの経験がない状態で勉強するには難しいような気がします。(少しでも経験があると理解できるでしょうが。。。)
その証拠としてかなり前から日本語プログラム言語が存在しているにも関わらず、その知名度の低さからもわかると思います。(2001年にひまわりが誕生しています。)

以前にプログラミングの経験があり、しばらくブランクがある人などがやってみると面白いのかもしれませんね。

言霊コミュニティサイト - 日本語で楽しくプログラミング
http://garuda.crew.sfc.keio.ac.jp/kotodamaCommunity/

日本語プログラム言語「なでしこ」公式ページ
http://nadesi.com/

ひまわり-日本語プログラミング言語
http://kujirahand.com/himawari/

TTSneo公式サイト
http://tts.utopiat.net/

K.Y
スポンサーサイト

テーマ:イベント・セミナー - ジャンル:コンピュータ

コメント
この記事へのコメント
コメントを投稿する
URL:
Comment:
Pass:
秘密: 管理者にだけ表示を許可する
 
トラックバック
この記事のトラックバックURL
この記事へのトラックバック
copyright © 2005 RIAトピックス all rights reserved.
Powered by FC2ブログ.
上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。